How to solve a rsInvalidReportServerDatabase error based on the wrong version of the database

The last couple of days I”ve been doing a standard deployment model of Reporting Services 2000.


I ended up with the following error:


The version of the report server database is either in a format that is not valid, or it cannot be read. The found version is ”C.0.6.43”. The expected version is ”C.0.6.54”. To continue, update the version of the report server database and verify access rights. (rsInvalidReportServerDatabase) Get Online Help


Unfortunately I was using Reporting Services 2000 because in 2005, you can upgrade the database with one single click using the Reporting Services Configuration Manager.


But anyways, I was stuck with this error. I came accros some answers in groups that say you have to reinstall Reporting Services. Pfff, I must of reinstalled it like three times with no luck.


Apparently installing SP1, reboot, install SP2 and reboot did the trick. I performed this procedure twice on two different occasions with the same error so I guess that must be the way to do it.


I hope this information can be of help to someone because it took me a very long time.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>